Linux dans toute sa splendeur

J’ai mon propre serveur Linux depuis quelques années et ne m’en suis pas occupé. Cependant, il commence à être de plus en plus obsolète, notamment parce que le PHP est en version 5.4 qui date de plusieurs années.

Je décide donc de faire une mise à jour. Problème ! Pour mettre à jour PHP, il faut que mes paquets soient à jour. En essayant de faire des apt-get update ou apt-get upgrade, j’ai des tas d’erreurs de route not found vers une URL mirror.ovh.net

Après quelques recherches, je finis par trouver que c’est le fichier /etc/apt/sources.list qui contient une commande disant à mon Linux d’aller chercher ses paquets sur cette URL moisie. Je la vire : j’ai maintenant des histoires de paquets introuvables car il manque des lignes dans le ficiher sources.list (je vous passe les 3 ou 4 forums ou sites différents qu’il faut consulter à chaque fois, car toute bonne réponse Linux oublie la moitié des information : leur erreur préférée étant de ne pas donner les chemins complets des fichiers, comme si toute le monde savait bien évidemment dans quel dossier se trouver le fichier sources.list …)

Ensuite, j’ai des erreur SSH : je me dis que ma version de TLS doit être obsolète. Problème : pour mettre à jour cela, et après recherche, il s’avère que je dois mettre à jour Wget : les anciens versions de Wget auraient un bug et un mauvais support des dernières versions du HTTPS (ou du SNI.. peu importe). Pour mettre à jour Wget, il faut faire un appel curl. Mais je n’ai pas curl. Du coup, Cca ne marche pas en mettant à jour le paquet php5-curl, donc je dois compiler Curl. Je le télécharge (avec Wget.. j’ai eu peur de boucler sur l’erreur précédente, mais heureusement non!). Ensuite je dois faire un make. Make n’est pas installé. Je dois alors télécharger apt-get install build-essential.

Du coup curl est installé. Du coup je peut retélécharger la « bonne » version de Wget.

Mais je n’arrive pas à l’installer car « GNUTLS is not available ». On me dit de tirer automatiquement les dépendances via un « apt-get build-dep wget ». Je retente la compilation de Wget. Ca marche. Je peux alors repasser à la mise à jour de mon PHP, qui fait des appels HTTPS utilisant Wget. Même erreur. Tiens, ma version de Wget est toujours la 1.13.4, que s’est-il passé ? Ah mais c’est bien sur, le wget s’est copié dans /usr/local/bin (donc que pour moi), mais pas dans /sur/bin. Je le recopie à la main (ca serait trop simple que le système te demande si tu veux tous les écraser ou pas..)

J’ai moins d’erreur, mais ca plante encore pour télécharger une mise à jour de Varnish. Je cherche donc comment exclure un paquet de la màj, car cet idiot fait tout planter sous prétexte qu’un paquet n’est pas trouvé (là encore, c’est trop demander que d’avoir une invite, c’est tellement plus génial de passer des as de paramètre -xyz sur la ligne de commande pour répondre par avance à toutes les questions que tu as deviné qu’on va te poser..)

Je fais un « apt-mark hold varnish » et relance ma màj. Waow on dirait que ça a marché. Comme c’était trop facile. Dire que ces méchants sous Windows ont juste à télécharger une nouvelle version (de WAMP ou autre chose) et écraser

Bien sur chacun de ces téléchargements, étapes, recherche sur des forums, prendre quelques minutes.

A la fin, tout le monde se demande pourquoi personne ne veut utiliser Linux, et pourquoi l’informatique ça coûte toujours cher pour pas grand chose. Les réponses sont dans cette histoire.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.